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The Forest Department of Bangladesh leads actions to improve forest management and conservation, 

adopting forward thinking, innovative approaches in its management of approximately 1.55 million hectares 

of land across the country.  

In 2015, the Forest Department began a process to establish a National Forest Inventory and Satellite Land 

Monitoring System for improved forest and natural resource management. The process supports national 

objectives related to climate change mitigation and provides information in support of the UN REDD 

programme aimed at Reducing Emissions from Deforestation and Forest Degradation (REDD+). The process 

also addresses domestic information needs and supports national policy processes related to forests and the 

multitude of interconnected human and environmental systems that forests support. 

The activities implemented under the Bangladesh Forest Inventory process are collaboration between 

several national and international institutions and stakeholders. National partners from multiple 

government departments and agencies assist in providing a nationally coordinated approach to land 

management. International partners, including the United Stated Agency for International Development 

(USAID), the Food and Agriculture Organization of the United Nations (FAO) and SilvaCarbon are supporting 

the development of technical and financial resources that will assist in institutionalizing the process.  

The results will allow the Forest Department to provide regular, updated information about the status of 

trees and forests for a multitude of purposes including for assessment of role of trees for firewood, 

medicines, timber, climate change mitigation. 

CONTACTS:  

Md. Mozaharul Islam  

National Project Coordinator and  

UN-REDD National Focal Point 

Bangladesh Forest Department 

Email: mazhar.raj@mail.com 

Matieu Henry  

Chief Technical Advisor 

Food & Agriculture Organization of The United Nations 

Email: matieu.henry@fao.org 

 

Suggested Citation: Hoque, A. (2017). Training on Basic Quantum Geographic Information Systems 

(QGIS). Bangladesh Forest Department and Food and Agricultural Organization of the United Nations. 

Dhaka, Bangladesh.  

 

Disclaimer 

This report is designed to reflect the activities and progress related to the Bangladesh Forest 

Inventory process. This report is not authoritative information sources – it does not reflect the official 

position of the supporting international agencies including USAID, FAO or SilvaCarbon and should not 

be used for official purposes. Should readers find any errors in the document or would like to provide 

comments for improving its quality they are encouraged to contact one of above contacts. 
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1. Background 
The first national forest inventory for Bangladesh was implemented in the year 2005 with the support 

from FAO. The inventory was conducted using a systematic sampling design, based on measurement 

of 299 plots distributed across the entire country. Based on the existing national forest assessment 

data and additional accessible field inventory and model data, the aim of this training is to provide 

support on data management and analysis, quality control and assurance.  

Field Papers is a web based tool developed by Stamen Design which creates printable map atlases for 

anywhere in the world that can be taken out into the field. Notes and sketches can be applied directly 

to the print out, which can then be photographed or scanned and uploaded back to the website. User 

doesn’t need a GPS to make a map or learn complicated desktop GIS software to use Field Papers. This 

project is a continuation of Walking Papers, which was built for the OpenStreetMap (OSM) editing 

community. Field Papers allows to print multiple-page atlases using several map styles (including 

satellite imagery and black and white cartography to save ink) and has built in note annotation tools 

with GIS format downloads. Even though user can use Field Papers without creating an account. 

OpenStreetMap (OSM) is a collaborative project to create a free editable map of the world. The 

creation and growth of OSM has been motivated by restrictions on use or availability of map 

information across much of the world, and the advent of inexpensive portable satellite navigation 

devices. OSM is considered a prominent example of volunteered geographic information. 

QGIS (previously known as Quantum GIS) is a community driven free and open-

source desktop geographic information system (GIS) application that provides data viewing, editing, 

and analysis. Similar to other software GIS systems, QGIS allows users to create maps with many 

layers using different map projections. Maps can be assembled in different formats and for different 

uses. QGIS allows maps to be composed of raster or vector layers. Different kinds of raster images are 

supported, and the software can georeference images. QGIS has a small file size compared to 

commercial GIS's and requires less RAM and processing power; hence it can be used on older 

hardware or running simultaneously with other applications where CPU power may be limited. QGIS 

supports dxf, shapefiles, coverages, and personal geodatabases. MapInfo, PostGIS, and a number of 

other formats. Web services, including Web Map Service and Web Feature Service, are also supported 

to allow use of data from external sources.  

A number of public and private organizations have adopted QGIS. Innovative use of QGIS plugins such 

as Open Street Map (OSM) may also provide efficiencies for the inventory process. OSM’s 

functionality that provides geo-referenced printed maps that can be marked in the field and then 

uploaded and digitized may be useful for monumenting permanent sample inventory plots and assist 

in the archiving process.  

Objective 

 Identify baseline capacity of GIS capacity external to RIMS 

 Increase sustainability of GIS capacity at FD by targeting participants outside of RIMS 
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 Increase capacity on basic GIS operations 

Used Methodology  

The training followed a structured and sequential method on the basis of the needs and the training 

methodology was fully interactive and hands on with the participation of 14 forest officers and RIMs 

officials.  

 Participants went to the pilot social forest area to map the forest cover using fieldpapers. 
 Printed agenda was provided to all the participants and all were presented and discussed in 

an easy, understandable manner.  
 All the training sessions were interactive and the questions and difficulties were solved during 

practice session.  
 All the participants were tested to know their enhanced capacity through a subject oriented 

test. 

 

2. Basic Introduction on OpenStreetMap 

2.1 Starting the iD Editor 

 To use iD you will need to be connected to the internet. 
 Open your internet browser, and go to the OpenStreetMap website at 

http://www.openstreetmap.org. 
 Login using your OpenStreetMap account 
 Pan and zoom the map to the area that you want to edit. 
 Click on the small arrow next to Edit. Then click Edit with ID (in-browser editor). 

 
iD Editor User Interface 

http://www.openstreetmap.org/
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1. Feature Panel: This panel shows tags from the object selected on the map. You can 
add or edit tags from this panel. 

2. Tools: This panel shows basic editing tools:  

o Draw point  

o Draw line  

o Draw shape (polygon)  

o Undo  

o Redo  

o Save changes  
3. Map panel: This panel show various configuration functions:  

o Zoom In  

o Zoom Out  

o Go to your location  

o Configure background layer  

o Open Help Menu  
4. Information panel: This panel shows various information, such as which users have 

contributed to the area. 
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2.2 Configuring the Background Layer 

Before you start editing, you can change the background layer. 

 Click the Background settings button. 

 You will see a panel like this: 

 

 You can change the brightness level by clicking one of these boxes: 

 There are 3 different brightness levels - 100%, 50%, and 0%. Click all of them to see 
the difference. 

 You also can change the background layer based on your desired tile provider (the 
default is Bing Aerial Imagery). Try the various options available from this list. 

 You can add your own map tiles by clicking on Custom. 
 For example, if you want to add a Field Paper, click Custom and enter your FieldPaper 

snapshot URL, which will be something like this: 

http://fieldpapers.org/snapshot.php?id=cqhmf2v9#18/37.80593/-122.22715 

http://fieldpapers.org/snapshot.php?id=cqhmf2v9#18/37.80593/-122.22715
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 You also can display GPS tracks from your computer (GPX format). It is very easy - just 
drag the GPX file into ID editor. 

 If there is imagery offset, you can correct the imagery offset by clicking Fix 
Misalignment. 

 

 Click the navigation buttons to move the imagery. Click the reset button to return to 

the default position.  

 

2.3 How to Upload GPS Data ? 

 
1. Go to the main OSM page. 
2. Login (remember you need an OSM account by signing up here). 

3. Click “GPS traces” along the top. 

4. Click on "See just your traces, or upload a trace". 

5. In the 3 boxes at the top do the following: 

1. Find and select the file you wish to upload (it should be .gpxformat) 

2. Name the file. 

3. Add helpful tags that can be used to find it such as “London UK” (each word is a tag in 

itself, so Isle of Wight should be "IOW" or "Isle-of-wight"). 

6. If you would like your data to be available to others (encouraged) tick the "Public?" box. 

7. Click "Upload". 

http://learnosm.org/en/editing/aerial-imagery
http://www.openstreetmap.org/
http://www.openstreetmap.org/create-account.html
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8. The data will now take a short while to be included into OSM. However, as soon as you've 

uploaded it, you can immediately use it. 

 

2.4 BASIC EDITING WITH iD 

Before we start practicing with iD, pan and zoom to a location that you familiar with. You 
can pan by holding the left mouse button and dragging the map to your desired area. 

Adding Points 
 To add a new point, click on the Point button. 
 Your mouse cursor will change into plus (+) sign. Now, click on a position that you 

know to mark a location. For example, if you know that there is a hospital in your 
area, click on the hospital building. 

 

 Notice that a new point is added. At the same time, the left panel will change to show 
a form where you can select attributes for the object. Click Hospital to tag the point as 
a hospital. 
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 You can use the forms to fill detail information about your point. You can fill hospital 
name, address, and/or other additional information. Note that each feature will have 
different form, depending on what tag you choose from the feature panel. 

 If you make a mistake, such as a wrong location, you can drag your point to a new 
location by holding the left mouse button on your point. Or, if you want to delete your 
point click the left mouse button on the point and then click the button which looks 
like a trashcan. 

A “point” created in the iD editor is actually a standalone “node” with a set of “tags” on it. 

Drawing Lines 

 To add a new line, click on the Line button. 

 Your mouse cursor will change into plus (+) sign. Find a road that hasn’t been drawn 
on the map and trace it. Click once on a point where the road segment begins, move 
your mouse, and click to add additional points. Double-click to end the drawing 
process. Notice the panel on the left. 
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 Just as with a point, select the appropriate tags for your line. 
 You can drag points from the line by clicking your left mouse button on a point and 

dragging it. 
 You also can move the whole line by selecting it, and choosing the Move tool. 

Then drag the line to a new position. 

 When you click your left mouse button on a point from the line, you will see these 
tools: 

o Delete point from line  

o Disconnect point from line  

o Split a line into two line from the point you’ve selected  
 When you click your left mouse button on a line, you will see these tools: 

o Delete line  

o Create a circle from a line (only active if the line is closed)  

o Move line  
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o Form a square shape from a line (only active if the line is closed)  

o Reverse line direction  

A “line” created in the iD editor is actually a “way” with “tags” on it. 

Drawing Shapes (Polygons) 

 To add a new shape, click on the Area button. 

 Your mouse cursor will change into plus (+) sign. Try to trace a building using the 
imagery as a guide. 

 You will notice that the color of your shape will change depending on the attributes 
that you assign to it. 

 

 The tools that are available when you select a shape are similar to those when you 
click on a line. 

A “polygon” in the iD editor is actually a “closed way” with tags on it. 
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Saving Your Changes 

 When (and if) you want to save your edits to OpenStreetMap, click the Save button. 
The panel on the left will show the upload panel. 

 

 Enter a comment about your edits and click Save. 
  

Additional Information and Custom Tags 

 When you are editing and object, you will see a strip of icons at the bottom of the 
attribute panel. You can add additional information by clicking these icons: 

o Add elevation  

o Add notes  

o Add contacts / phone number  

o Add source tag  

o Add website  
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o Add accessibility information  

o Add Wikipedia link  
 Or, you can add custom tags by clicking All tags. 

 

 This will show all the tags attached to the feature. 

 

 Click the plus sign (+) to add keys and values or click the trash icon to delete tags. 
 

ADDING TAGS 
In the previous section you learned about OpenStreetMap's geo elements. It is time to learn a little 
about OpenStreetMap's tagging scheme. The basic tagging scheme can be found in Tagging. The 
tagging page links to the Map Features page which lists most of the keys accepted by the OSM 
community. Many of the examples on the Map Features page, particularly those regarding roads, are 
specific to the U.K. Users in other countries will want to look at Tagging for guidance in applying the 
tagging scheme to their country. 
 

Types Of Geo objects 
OpenStreetMap's Tagging Scheme has 3 data types that may be tagged: 

 
Node: Just a node/point used to mark a particular point on the map. For example: 

 A town may be marked using a node tagged with place=town. 

 A theatre may be marked using a node tagged with amenity=theatre. 
 
Linear: A way used to mark a particular linear item on the map. For example: 

 A motorway may be marked using a way tagged with highway=motorway. 

 A river may be marked using a way tagged with waterway=river. 
 
Area: A closed way to mark a particular area on the map. For example: 

 A lake may be marked using an area tagged with the natural=water. 

 A town may be marked using an area tagged as place=town. 
 

http://wiki.openstreetmap.org/wiki/Beginners_Guide_1.3
http://wiki.openstreetmap.org/wiki/Tagging
http://wiki.openstreetmap.org/wiki/Map_Features
http://wiki.openstreetmap.org/wiki/Map_Features
http://wiki.openstreetmap.org/wiki/Tagging
http://wiki.openstreetmap.org/wiki/Tagging
http://wiki.openstreetmap.org/wiki/Key:place
http://wiki.openstreetmap.org/wiki/Key:place
http://wiki.openstreetmap.org/wiki/Tag:place%3Dtown
http://wiki.openstreetmap.org/wiki/Proposed_features/Theatre
http://wiki.openstreetmap.org/wiki/Key:amenity
http://wiki.openstreetmap.org/wiki/Tag:amenity%3Dtheatre
http://wiki.openstreetmap.org/wiki/Key:highway
http://wiki.openstreetmap.org/wiki/Key:highway
http://wiki.openstreetmap.org/wiki/Tag:highway%3Dmotorway
http://wiki.openstreetmap.org/wiki/Key:waterway
http://wiki.openstreetmap.org/wiki/Key:waterway
http://wiki.openstreetmap.org/wiki/Tag:waterway%3Driver
http://wiki.openstreetmap.org/wiki/Key:natural
http://wiki.openstreetmap.org/wiki/Tag:natural%3Dwater
http://wiki.openstreetmap.org/wiki/Key:place
http://wiki.openstreetmap.org/wiki/Key:place
http://wiki.openstreetmap.org/wiki/Tag:place%3Dtown
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2.5  Java OpenStreetMap Editor (JOSM)? 

Java OpenStreetMap Editor is a desktop editing application, written in Java. It runs on Windows, Mac 
OS and Linux. It supports loading standalone GPX tracks and GPX track data from the OSM database as 
well as loading and editing existing nodes, ways, metadata tags and relations from the OSM database.  
Interface is a bit bare until some data is loaded. 

 
JOSM welcome page 

 

INSTALLING JOSM 
Download the latest JOSM version (josm-tested.jar) from  
http://josm.openstreetmap.de/ ; or ;  http://wiki.openstreetmap.org/wiki/JOSM  
 
There area generally two versions of JOSM available: 

1. tested and 
2. latest 

 
The tested version of JOSM is more stable while the latest is more up-to-date but can contain bugs. 
There are fairly regular updates to JOSM, so always try running a recent version (and also recent 
plugins). 
 
JOSM version is distributable as executable JAR file which can usually be run just by double clicking if 

Java is correctly installed. You are ready to go! 

 

http://josm.openstreetmap.de/
http://wiki.openstreetmap.org/wiki/JOSM
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JOSM USER INTERFACE 
Run JOSM by double clicking the JAR file. Once JOSM is successfully launched the main window 
appears. At startup, the window shows the Massage of the Day, downloaded from the JOSM 

website  
Map View– The main window where the geodata is displayed and editing takes place. 
Main Menu– The menu is customizable depending on which plugins you have installed. 
Shortcut Toolbar– The buttons in this toolbar are shortcuts to commands from the Main Menu. This 
toolbar is highly customizable, with the ability to add and remove menus items from the preference 
dialog. 
Edit Tools – Contains drawing tools and the show/hide buttons for the Toggle Dialogs window.  
Information Panels – These show information about the data in JOSM, including a list of selected 
objects, how the elected objects are tagged, who the last mapper to edit a feature was, and the 
different layers in the view.  
Status Bar –Gives coordinates and measurements for features, as well as a hint of the current tools 
function. 
 

DOWNLOAD DATA FROM OSM 
To download map data from the OSM server: 

 Press File> Download from OSM...or the icon on the 
Main Toolbar or press Crtl+Shift+D . The download dialog box appears:  
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Slippy map 

 
Initially the 'slippy map' tab is selected. Slippy map provides a movable map like on the OSM front 
page with which you can interactively select the area to download. Move or “Slip” around the map by 
dragging the right mouse button. Zoom by using the mouse scroll-wheel or by double-clicking. 
 
Download data: 

 Download dialog box 

 Use the left mouse button to drag a box around the area you want to download (this is the 
bounding box that will be downloaded) > press Download 

 Data should appear in the main Map View Window 
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You should download the area encompassing the area you will be editing but avoid downloading too 
much map data. You can always download more data as you need it. “Cross hatching” will be shown 
outside the area that you downloaded to remind you that you should not edit outside the area that 
you download from the server. The items outside the bounding box are included because they are 
included inside the bounding box.  
 
There are other ways to specify the area you want to download: 
Bookmarks 

 You can select from your predefined bookmarks or create a new bookmark from your current 
bounding box or an area defined in another tab respectively. 

 
Bounding Box 

 Select an area by entering the latitudes and longitudes directly or by extracting them from an 
openstreetmap.org  URL. 

 
Download data by pasting from the map on the OpenStreetMap site: 

 Zoom into the area you are interested in 

 Move the mouse over the “view” tab and copy the resulting URL or copy the Permalink given 

 at the bottom right corner 

 Copy the URL  

 Paste the URL into JOSM, into the “URL from openstreetmap.org” box  
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Copy the URL into the Download Bounding Box tab: 

 
 Copy URL into Bounding Box 

 Areas around places 

 Search for specific places, street names, etc., in the OSM database.  

 Tile Numbers 

 Enter number of tiles and a zoom level to download data of those tiles.  
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WHAT ARE PRESETS? 

A preset is a predefined combination of tags (sometimes a single tag) that is given a “human-
readable” 
name. 
 
The presets menu contains a list of presets organized in thematic groups. Presets allow the user to tag 
objects by selecting them from the predefined menu. JOSM installation comes with a default set of 
these presets.  
 

FIND PRESETS: 
In JOSM go to Main Menuand press Presets 

 
When applying a preset to an element of the map, a dialog window may appear allowing the user to 
enter more precise and/or specific data. For example, the preset “Sports/Sport facilities/Stadium” will 
apply the tag leisure = stadium and will ask the user to enter the value for the optional keys name and 
sport. A list of common sports is suggested. 

 
Applying the preset "Stadium" to a node 
 
If a tag is included in a preset, an additional line will be displayed in the “Properties/Membership” 
panel, above the list of tags as shown below. Clicking on this line will open the preset dialog box 
shown above. 



22 
 

 
 

PRESET PROPERTIES 

The users can create, add, modify and use their own presets, for example in specialized use cases like 
event mapping etc. (more on this in Advanced Editing). 
 
 Add a tag 
Add a new tag by using an ‘Add A Tag’ button: 

 Press the button Add a Tag   
 

 Change values window appears where you can select a key or a value from the drop-down list. 
The drop-down list contains all the values in the downloaded area and all the know tags or 
presets. 

 
Add a tag by using predefined Presets: 

 Select a tag from Presets by pressing Presets tab on the Main Menu 

 Select a tag from the drop-down 

 Select the attributes  

 Press Apply Preset 

 
 

2.6 FIELD PAPERS  

Field Papers, which was created by Stamen Design and is the update of a tool called Walking Papers, 
allows us to print a map of a selected area, draw on it, add notes to it, and then open it in an 
OpenStreetMap editor like iD to digitize the drawing. 

http://fieldpapers.org/
http://stamen.com/
http://walking-papers.org/
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Create and Print Field Papers 

1. Open your web browser. In the address bar at the top of the window, 
enter http://fieldpapers.org/ and press Enter 

2. The website should look something like the figure below: 

 
Interface Field Papers 

3. Click Make yourself an Atlas to select the area that you want print out. 

http://fieldpapers.org/
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4. You will be directed to a page like this where you can see there are some setting at 
left panel and main map at the right. 

 
Compose Field Papers 

5. On the main map, to find the area that you want to map, you can click search button 

and type the location name OR you can drag manually the map with the same way when 
you drag map in OpenStreetMap website, use the left button your mouse for drag map, 

and scroll your mouse for zoom in and zoom out. Click on + and - buttons in the upper 

left corner for zoom in and zoom out. 
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Setting the area in Field Papers 

Here you also can define the boundaries of your Field Papers. The boundaries is displayed as 
hollow box with black border. You want to make sure that the window displays the area of 
interest that you intend to map. You can add more page or less page. Make sure that your 
map can display building and road for field survey. 

 
Setting the page in Field Papers 

6. At the left panel are some setting for print out Field Papers. The first is give 
information to your atlas by type a name on the Atlas Title column.  
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7. The second is the Grid Layout setting. The Paper Size is used to adjust the paper size 

that you want use for printing out Field Paper. You can choose letter, A3, or A4. Then 

the Orientation is used to adjust the paper orientation that you want use for print out 

Field Paper. You can choose between portrait or landscape as shown in the figure below. 

 
Setting the paper size and paper orientation in Field Papers 

8. Still in Grid Layout setting, next you can select the type data for your Field Papers. You 
can select different Basemap for change map background. In this example shown in the 

figure below, we will select Satellite Only. 

 
Setting Map Background on Field Papers 

9. When you’re finished, click MAKE ATLAS 
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Next step to create Field Papers 

10. It may take a few minutes to prepare your final Field Papers map. When finished, you 
will see your Field Paper on this page, shown in the figure below. 

 
The process preparing Field Papers 

11. When your print is ready, Click Download PDF. The Field Paper should begin 

downloading. If it loads in your browser, you may need to save it by going to File ‣ Save. 



28 
 

 
Download Field Papers 

When the download is finished, open the PDF file. Connect your computer to a printer and 
print the page. If everything goes well, you should now have map printed on paper. 
 
 
 

Scan and Upload Field Papers 

1. Field Papers are very useful for mapping with nothing more than paper, but they are not a 

100% solution. We will still need to load our paper map into JOSM, add our information digitally, 

and save our changes on OpenStreetMap. 

2. The first step is to scan your Field Papers into your computer. You can do this by attaching a 

scanner to your computer, scanning the paper, and saving it as an image file. If you don’t have a 

scanner, you can take a photography of the paper, but you should be careful to take a very good 

photo. Make sure that the paper is flat and your camera is directly in front of it. Be sure to include 

the barcode in the image, as Field Papers will not work without it. Here is an example of a 

scanned/photographed image: 
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Field Papers Image 

3. Once you have your Field papers scanned and saved on the computer, open your web browser 

and return to Field Papers website just as before. 

4. Click the Upload tab at the top of the page. 

 
Upload Field Papers 

5. Click Browse... and navigate to the file where you scanned/photographed your Field Papers. 
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Select the to be uploaded to Field Papers website 

6. It may take a few minutes for your paper to upload, depending on the speed of your connection. 

 
Field Papers uploading process 

7. When the upload finished, you can see the page interface as in the figure below: 

 
The result from upload Field Papers 



31 
 

 

Add Plugin Field Papers 
Before we open Field Papers in JOSM, we need install the Field Papers plugin. The fieldpapers plugin 
enables JOSM to open Field Papers that have been uploaded to the Field Papers website. The Field 
Papers will be used as background, and we open it using the same procedure for opening satellite 
imagery in JOSM. 

1. Open JOSM and go to Edit ‣ Preferences. 

2. Click on Plugins tab. 

3. Type fieldpapers  in the Search  box. After you find it, tick the fieldpapers box and Click OK as 

shown in the figure below. 

 
Field Papers Plugin 

4. Restart JOSM so the plugin loads. 

Open Field Papers from ID and JOSM 

1. Now you can add the results of your scanned Field Papers to ID or JOSM and add your 

information to OpenStreetMap. Return to the Field Papers website in browser address bar. 

2. Click Watch – move your mouse to the bottom and click Snapshots until your browser 

page looks like the figure below: 

 
List Field Papers in Snapshots 

http://fieldpapers.org/
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To use scanned Field Papers in the online ID Editor or Potlatch2 by clicking the link Edit in... 

ID or Edit in... Potlatch on page Field Papers that have been scanned. 

 

Editing Field Papers with iD Editor 

 

Interface Editing OSM data on iD Editor 

3. To open Field Papers in JOSM, we need copy the photo ID from the Field Papers that have 

been scanned. We can get the ID from the snapshot URL at the Field Papers website. Click on the 
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image until the url appears as shown below, then copy the URL for 

example: http://fieldpapers.org/snapshots/cdq5bfq4#17/-6.81299/107.61451 

 
URL from Snapshot Field Papers 

4. Copy the URL by selecting it and pressing CTRL + C. 

5. Open JOSM and make sure the Field Papers plugin is listed in the menu on the top of toolbar. 

Click Field Papers ‣ Scanned Map... 

 
Field Papers Menu in JOSM 

6. Then paste the URL that we have copied from the Field Papers site by pressing Ctrl + V on 

your keyboard. 

 
Input Field Papers URL in JOSM 

7. Click OK. 

8. If everything goes well, the Field Papers will open in JOSM. The next module, we can see how 

to add objects from the scanned Field Papers to OpenStreetMap. 
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Interface Field Papers in JOSM 

 

Exercise! 

After you add your changes to OSM, they will be saved to the OSM servers. When you want 

add some information to your map, you can print a Field Paper that includes the changes you 

made. As this process is repeated, and you acquire more details, the map will steadily improve! 

Summary 

In this module, You have learned how to use Field Papers and how Field Papers works as a 

data collection device. You have learned how to print, mapping, and scans Field Paper, and 

how you can use them to improve OpenStreetMap.  

 

 

3. Loading and Integrating Different Formats of data with QGIS 

3.1 GPS to QGIS 

There are dozens of different file formats for storing GPS data. The format that QGIS uses is 

called GPX (GPS eXchange format), which is a standard interchange format that can contain 

any number of waypoints, routes and tracks in the same file. 
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To load a GPX file you first need to load the plugin. Plugins‣  Plugin Manager... opens the 

Plugin 

Manager Dialog. Activate the  GPS Tools checkbox. When this plugin is loaded two 

buttons with asmall handheld GPS device will show up in the toolbar: 

 

  

 

Create new 

GPX Layer 

GPS Tools 

For working with GPS data we provide an example GPX file using which the following 

steps have to be performed- 

1. Select Vector‣GPS‣GPS Tools or click the  GPS Tools icon in the toolbar and open 

theLoadGPX file tab (seefigure_GPS_1). 
2. Browse to the folder qgis_sample_data/gps/, select the GPX file 

national_monuments.gpxand click [Open]. 
 

 

 

 

 

 

 

 

 

 

 

Figure 1.:The GPS Tools dialog window

http://docs.qgis.org/2.0/en/docs/user_manual/working_with_gps/plugins_gps.html#figure-gps-1
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Use the [Browse...] button to select the GPX file, then use the checkboxes to select the feature 

types you want to load from that GPX file. Each feature type will be loaded in a separate layer when 

you click [OK]. The file national_monuments.gpx only includes waypoints. 

Note 

GPS units allow to store data in different coordinate systems. When downloading a GPX file (from 

your GPS unit or a web site) and then loading it in QGIS, be sure that the data stored in the GPX file 

uses WGS84 (latitude/longitude). QGIS expects this and it is the official GPX specification. 

Importing GPS data 

To import GPS data from a file that is not a GPX file, you use the tool Import other file in the GPS Tools 

dialog. Here you select the file that you want to import (and the file type), which feature type you 

want to import from it, where you want to store the converted GPX file and what the name of the new 

layer should be. Note that not all GPS data formats will support all three feature types, so for many 

formats you will only be able to choose between one or two types. 

3.2 Loading Vector data (shapefile) 

Click the Add Vector Layer  button to add geospatial data (Figure 2), which opens a window (Figure 

3) 

 

 

 

 

                                Add data 

 

 

 

 

 

 

 

 

 

Figure 2. A. The Main Window : Add Vector Layer button  Figure 3.B. The Pop-up Window to "Add Vector Layer" 



37 
 

Then you can browse to the file you want to work with by clicking the Browse button just like any other 

file explorer dialogs in Windows. You can open multiple files at one time by holding the Ctrl or Shift 

button when you are clicking the mouse button to make selections. The by-default file filter is *.shp file 

(Figure 4). But there are many other choices, such as *.kml (Google Earth) and *.csv, much broader than 

ArcGIS. 

 

 

 

 

 

 

 

 

 

 

 

Figure 3. The File Open Dialog with File Filters 

For example, you can browse Khulna_Div.shp file from pov_khl folder that was provided in Practice 

Data folder as your sample dataset. 

 

3.3 Load Google Maps ,Bing Maps and Openstreet Maps: 

QGIS provides the flexibility of using Google (or Yahoo) Satellite images or Bing aerial images as a 
background layer in your map. To do so, follow the steps below: 

1. Install the OpenLayers Plugin into QGIS: 

a. Go to Plugins -> Manage and Install Plugins, which leads to a dialog. 

b. Type 'Openlayers Plugin' in the search box 

c. Click on 'Install plugin' and the 'Openlayers Plugin' will be  

installed in your QGIS. 

2. Add Google Satellite map as Background layer: 
 

 

 

 



38 
 

 

 

 

 

 

 

Go to the menu Web ->Openlayers plugin ->Add Google Satellite Map. 

 

 

 

 

 

 

 

 
3. Add Bing Aerial Map as Background layer: 

Go to the menu Web ->Openlayers plugin -> Bing maps-> Bing aerial. 

4. Add Openstreet  Map as Background layer: 

Go to the menu Web ->Openlayers plugin ->OpenstreetMap->OpenStreetMap 

 
 

3.4  Loading CSV File from excel and Modification of 

attribute table 

A CSV is a comma separated values file, which allows data to be saved in a table structured format. CSV 

can be converted from an excel file and it is more necessary when we are using the date in QGIS. QGIS 

directly supports CSV file rather than an excel file. So, if you have an excel data to join, you must 

convert it into CSV file and then load into QGIS. 

Conversion to CSV 

 Open the Excel file in Microsoft Office Excel and save it as a anew file 

 Click on File>Save As> Select CSV as Save as type> Save 
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Figure 4. Pop-up window of Excel Save as type option 

3.5 Loading CSV in QGIS 

Now, the excel file has been converted into a CSV file and will be loaded into QGIS. Click on Layer on 

menubar>Add Layer>Add Delimited Text Layer. The point to be noted that there are two types of 

tabular data: one contains geographic data (x, y coordinates) and another contains descriptive data 

having in details information. 
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4. Map/Print Composer 
When the geospatial data and its representations are satisfactory, you can add other map components 

in another window via Project-> New Print Composer (Figure 31). You can manage multiple composers 

via File - > Composer Title box will pop up. Entering the Title a new window will pop up. 

 

Figure 5. New Print Composer in Project menu 

Key components of publishing a map include: 

 The title of the map; 
 The scale of the map; 
 The North Arrow (Orientation); 
 The Legend (how to interpret the map); 
 (Optional) The reference (where you obtain the data) 
 Date of preparation and map preparing authority 

The main part, map, can be added by clicking in Layout>Add Map, and then drag a rectangle on the 
paper to define display area and extent. 

Map titles can be added as a text box by clicking and then click on the spot where you want to place 

the title at. Please note that, in print composer, you can customize the properties of all components by 

switching to the ITEM tab. So, for instance, if you want to change the font of the title, click the title first 

(so that it is selected) and change to the ITEM tab. There is a button called Font where you can find all 

properties there.  

Add scale bar is also intuitive: click on and then click where you want to add it. You can change Unit 

label and Style. The scale bar style can be numeric, i.e. 1:5,000,000, or different bar/line forms. All 

options are intuitive and can be tested by changing it back and forth.  

North Arrow can be added as an arrow. The options of a north arrow in QGIS are very limited. Legend 

can be added in the same way as others (click on ).  

QGIS has better organization of legend properties than ArcMap. The major options are located under 

Legend items. You can fine tune in Item Options. 
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Figure 6. Map Composer 

Now we can start to assemble our map.  

 Go to Project ‣ New Print Composer. 

 You will be prompted to enter a title for the composer. You can leave it empty and click Ok. 

Note 

Leaving the composer name empty will assign a default name such as Composer 1. 

In the Print Composer window, click on Zoom full to display the full extent of the Layout. Now we would 

have to bring the map view that we see in the QGIS Canvas to the composer. You can add the items by 

choosing from Layer tab or the Layer Panel at left of the canvas (Figure 33).  

 Go to Layout ‣ Add Map 

 Once the Add Map button is active, hold the left mouse button and drag a rectangle where you 

want to insert the map. 
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Figure 7. Layer Tab and Layer Panel 

You will see that the rectangle window will be rendered with the map from the main QGIS canvas. The 

rendered map may not be covering the full extent of our interest area. 

 Select Layout ‣ Move item content to pan the map in the window and center it in the composer. 
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 Let us adjust the zoom level for the given map. Click on the Item Properties tab and change the 

scale value adjusted the composer view as shown in figures below.  

 

 Now we will add a map inset that shows a zoomed in view for the Tokyo area. Before we make 

any changes to the layers in the main QGIS window, check the Lock layers for map 

item and Lock layer styles for map item boxes. This will ensure that if we turn off some layers or 

change their styles, this view will not change. 

 

 We can change the frame of the map using the Frame properties from Item Properties panel at 

right side 9see the figure below). 
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 Now we will add a North Arrow to the map. The Print Composer comes with a nice collection of 

map-related images - including many types of North Arrows. Click Layout ‣ Add Image. 

 

 Holding your left mouse button, draw a rectangle on the top-right corner of the map canvas. On 

the right-hand panel, click on the Item Properties tab and expand the Search directories section 

and select the North Arrow image of your liking as figure below 
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 Now that we have the map inset ready, we will add a grid and zebra border to the main map. 

Select the Map 0 object from the Items panel. In the Item properties tab, scroll down to 

the Grids section. Click the Add a new grid button. 

 By default, the grid lines use the same units and projections as the currently selected map 

projections. However, it is more common and useful to display grid lines in degrees. We can 

select a different CRS for the grid. Click on the change... button next to CRS. 

 In the Coordinate Reference System Selector dialog, enter 4326 in the Filter box. From the 

results, select the WGS84 EPSG:4326as the CRS. Click OK. 
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 Select the Interval values as 5 degrees in both X and Y direction. You can adjust the Offset to 

change where the grid lines appear. 

 

 We can change the Gid frame style from Grid frame panel, size, thickness etc as below.  
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 It is time to label our map. Click on Layout ‣ Add Label. 

 Click on the map and draw a box where the label should be. In the Item Properties tab, expand 

the Label section and enter the text as shown below.  

 

 

 Click on the layout where you want the scalebar to appear. In the Item Properties tab, make 

sure you have chosen the correct map element for which to display the scalebar.  

 Choose the Style that fit your requirement. In the Segments panel, you can adjust the number 

of segments and their size. 
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 Let’s add the legend of the map by clicking add legend from Layer Tab and place the legend by 

click and dragging of left button of your mouse where you wish to place. Legend will be shown 

as available in the main QGIS data view as you displayed. 
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Export Maps 

When you are satisfied with everything on the map and are ready to deliver, you can export your map 

as images, PDF, SVG, or print a hard copy. All options are under the File menu. You can specify the 

directory and file name of the map in this dialog. But, most importantly, you need to choose an 

appropriate file format by clicking on the Save as type dropbox. The most frequent-used formats are 

JPEG and PDF. JPEG is a popular graphic file format, which is easy to be inserted into word as a graph, 

while PDF is best used for sharing. The printed copy of PDF will be identical regardless of your computer 

(and printer) environment. 
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Appendix 
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